A highly configurable text editor built to creating and changing any text

MacVim

Join our mailing list

Stay up to date with latest software releases, news, software discounts, deals and more.

Subscribe
Download MacVim 9.0 Snapshot 178

MacVim 9.0 Snapshot 178

  -  19.6 MB  -  Open Source

Sometimes latest versions of the software can cause issues when installed on older devices or devices running an older version of the operating system. Software makers usually fix these issues but it can take them some time. What you can do in the meantime is to download and install an older version of MacVim 9.0 Snapshot 178.


For those interested in downloading the most recent release of MacVim or reading our review, simply click here.


All old versions distributed on our website are completely virus-free and available for download at no cost.


We would love to hear from you

If you have any questions or ideas that you want to share with us - head over to our Contact page and let us know. We value your feedback!

  • MacVim 9.0 Snapshot 178 Screenshots

    The images below have been resized. Click on them to view the screenshots in full size.

What's new in this version:

New Vim features:
- New built-in support for EditorConfig via an optional package. Use packadd editorconfig to activate it.
- g<End> now goes to the first non-blank char

API changes:
- undotree() now takes a bufnr v9.0.1686
- printf() now takes positional arguments v9.0.1704
- virtcol() now takes winid v9.0.1728
- quickfix items can now have user data v9.0.1688
- Miscellaneous security fixes

Security Fixes:
- Fixed insecure usages of interprocess communication in MacVim

Fixed:
- Fixed MacVim to correctly set up the runtime folder in the app bundle. As a corollary, xxd is now bundled with MacVim like most other Vim distributions, and MacVim.app now provides man page for the CLI vim commands if the user wants to associate man pages with the mvim comamnd (see :h macvim-PATH)
- Fixed Vim occasionally crashing and/or hung when autocmd calls serverlist() on exit

Scripting:
Scripting languages versions:
- Python now supports 3.9 or above

Join our mailing list

Stay up to date with latest software releases, news, software discounts, deals and more.

Subscribe